Upgraded to Windows 10 and UO seems laggy for some reason (HELP)

Discussion in 'Renaissance Discussion' started by Lumbo, Jul 25, 2018.

  1. Lumbo

    Lumbo Active Member

    Joined:
    Jan 20, 2017
    Messages:
    400
    Likes Received:
    166
    So I had a pretty fast computer before but always stayed on Windows 7. Bought a new one, processor is about 20% faster and it runs Windows 10 but everything else is more or less comparable (still 8 GB RAM, processor still an i7, etc etc). For whatever reason UO is running like I'm on dial-up. Seems 100 times worse when I have scavenger enabled but even with it disabled it's slower. Anyone ever had this issue that has any idea what's causing this? I put in a new video card but it's not much different than my old one (not that UO needs a card, just wondering if it's causing some conflict potentially...)
  2. Theodin

    Theodin Well-Known Member

    Joined:
    Feb 23, 2014
    Messages:
    424
    Likes Received:
    323
    Make sure you run in compatability mode and uncheck something from razor that's like "use smart cpu reduction" because it is anything but smart
    Animal Control and Lumbo like this.
  3. Ahirman

    Ahirman Well-Known Member
    UO:R Subscriber

    Joined:
    Mar 20, 2015
    Messages:
    1,003
    Likes Received:
    829
    I’m on Windows 10 and I run everything as admin compatibility mode winxp sp3.
    Lumbo likes this.
  4. Lumbo

    Lumbo Active Member

    Joined:
    Jan 20, 2017
    Messages:
    400
    Likes Received:
    166
    Thanks gents. Seems back to normal with compatibility mode (FWIW it suggested Vista).
    wylwrk likes this.
  5. Andrakus

    Andrakus Member

    Joined:
    Jun 28, 2018
    Messages:
    36
    Likes Received:
    9

    How do you do that?
  6. Dr Satan

    Dr Satan Well-Known Member

    Joined:
    Apr 29, 2015
    Messages:
    1,758
    Likes Received:
    2,236

Share This Page